2009
09.02

logo php Wordpress, 1&1 et erreurs 500

Si vous utilisez conjointement WordPress et l’hébergeur 1&1, vous avez probablement dû rencontrer un jour ou l’autre le problème suivant :

error500 Wordpress, 1&1 et erreurs 500

Et là fatalement vous vous dîtes « Mais bordel c’est quoi ces conneries d’erreurs à la *$#!@>< » (forcément ça énerve).

Cette erreur peut être rencontrée dans différents cas de figures, principalement lors de l’activation d’un plugin ou lors de l’upload d’une image.

Le problème vient du fait que la version de php installée sur les hébergements 1&1 est obsolète (sisi!). En effet, 1&1 utilise php4 sur ses serveurs, or wordpress utilise pour la plupart de ses derniers plugins php5.

Pour palier à ce problème, il suffit de rentrer les 2 lignes suivantes dans un fichier .htaccess à la racine de votre FTP.

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

Be Sociable, Share!
  • more Wordpress, 1&1 et erreurs 500

Aucun commentaire.

Ajoutez votre commentaire